Magento 1.7 Erro no Admin / Backend

Eu estava instalando a última versão estável do Magento Community que é a 1.7.0.2 e após de instalado uma série de erros chatos apareceram. Muitos dos erros principalmente com as url's amigáveis podem ser corrigidos no admin, pois geralmente é o ajuste de alguma configuração. No entanto, ao acessar alguma página interna das configurações no admin, a surpresa: Nenhuma página estava aparecendo! Somente a seguinte mensagem de erro:

There has been an error processing your request  Exception printing is disabled by default for security reasons. Error log record number: 974616504082

Que não diz muito, mas como é de praxe é só olhar o log no servidor. Bom como eu estava acostumado com uma versão mais antiga do Magento fui verificar em /public_html/var/log porém ao procurar a pasta "log" ela não existia! Eu pensei que o Magento não estava criando o log, como alguns comentários no fórum diziam. Mas que nada! Depois de um tempo fui descobrir que o log do magento agora fica na pasta report e onde o código de erro acima é o nome do arquivo. Deste modo, ao abrir o arquivo encontrei na primeira linha o erro correto que é o seguinte:

Could not determine temp directory, please specify a cache_dir manually

Este é o verdadeiro erro que estava prejudicando o funcionamento correto do backend! Para solucionar faça o seguinte:

  1. Vá em "lib/Zend/Cache/Backend/".
  2. Abra o arquivo "File.php".
  3. Na linha 91 procure a seguinte expressão "'cache_dir' => null"
  4. Neste expressão podemos notar que o diretório temporário não foi especificado, assim temos que criar um diretório temporário.
  5. Como a maioria dos caches e diretórios temporários estão em no diretório "var", fui lá e criei mais um chamado "znd_cache".
  6. Agora no passo 3 acima, no lugar de "null" coloquei o caminho do diretório temporário recém criado: "'cache_dir' => 'var/znd_cache'".
  7. Pronto! Feito isso o Backend volta a funciona corretamente.
Maiores dúvidas só deixar um comentário abaixo, espero ter ajudado.
  • Iraquedan

    Amigo o meu problema e diferente na segunda parte da instalação do magento ele pede a url base ex: meudominio.com.br/magento e na linha seguinte admim, mas quando mando continuar ele da erro de url diz que é invalida a url não sei mais oque fazer… lembrando que não estou fazendo isso local estou fazendo direto no meu server web. desde ja grato.

  • Olá, algo muito provável que pode estar dando este erro é com relação as URLs amigáveis. Muito possivelmente seu servidor não dá suporte. Você tem o arquivo .htaccess configurado corretamente? Na instalação na parte de configurações, onde você fornece alguns dados com relação ao endereço do seu site como você está configurando? Experimente uma opção se não der outra, qualquer coisa mande um printscreen (pode utilizar o http://snag.gy/) de como você está configurando para facilitar o entendimento do seu problema.

  • Iraquedan

    O suporte realmente não ajudou, acho que .htaccess esta configurado corretamente no passo a passo ele pede para dar permicao 777, fiz isso no diretorio public/magento/var/.htaccess, e na verdade nao sai da segunda parte apena coloquei o magento em portugues e a moeda local, na seguinte pagina ele da esse problema pode me passar um email para eu passar o ptrsc?

  • Iraquedan

    http://snag.gy/8QjK0.jpg da uma olhada ae.

  • Você selecionou esta opção?
    http://www.phpnx.com/wp-content/uploads/2012/12/magento_installation_57.jpg

    Aqui neste sistema de comentários é possível enfiar imagens no cantinho inferior esquerdo tem um botão de envio.

  • Iraquedan

    Sim a primeira opção e a de reescrita do apache. no caso a terceira

  • Iraquedan

    Amigo desculpe nao tinhe selecionado esta opcao selecionei agora… e advinha? funcionou fui para a pagina seguinte vou continuar e ver se funciona qualquer posso te procurar?

  • Beleza agora estou de saída mas durante a noite se tiver mais alguma dúvida dou uma força. Boa sorte.

  • Iraquedan

    Obrigado!!!

  • Boa tarde,
    Estou com este erro persistente, o pior que faço tudo que é mencionado acima e quando vou acessar o admin ou a loja a página fica em branco. Qual ajuste preciso efetuar?
    osvfilho59@gmail.com

    excompras.com.br

    Grato.

  • wanderley albuquerque

    faltou um passo para criar a pasta znd_cache e dar permissão de escrita e leitura, mas me ajudou bastante. obrigado.

  • Fernando Zorek

    Perfeito, salvou minha vida! rss

  • Alisson Silva

    como eu crio o passo 4? FIZ a Atualização do Magento mais no meu admin so funciona a pagina principal todas as outras da o erro mencionado no post

  • Prof. Renato de Carvalho

    Não funciona, continua dando erro 404